服务器711升级至8.0

编辑
文档创建者:印然 (67260 )     浏览次数:2922次     编辑次数:9次     最近更新:susie 于 2017-12-20     

目录:

1. 描述编辑

8.0平台做了很大改动,好处很多,解决了经常权限丢失的问题,以及可自定义平台主题等等。当然随之而来的问题就是兼容!
因此我们开发出这么一款插件,安装711升级8.0平台兼容插件后,就可以放心升级,不再存在兼容问题。
注:该插件只支持8.0最新版本,若要使用该插件,先升级至最新8.0。
下面介绍详细的升级步骤

2. 升级和插件的安装编辑

2.1 将工程部署至服务器

将7.1的工程拷贝到tomcat安装目录下的webapps文件夹下,如图:

222

注:该文档默认报表工程是WebReport,如实际报表工程不是WebReport,以实际报表工程为准,路径都是一样的

操作完后,启动tomcat,登陆http://ip:端口号/WebReport/ReportServer?op=fs访问决策平台,看到登陆界面就表示部署成功。

然后本地安装一个8.0的设计器,安装在一个全新的目录。

2.2 备份拷贝jar包

备份的jar包:

WebReport目录下的fr-applet-7.1.jar;WEB-INF/lib文件夹下的fr-server-7.1.jar和fr-third-7.1.jar

拷贝的新jar包:

fr-third-8.0.jar、fr-chart-8.0.jar、fr-core-8.0.jar、fr-performance-8.0.jar、fr-platform-8.0.jar、fr-report-8.0.jar:从本地安装目录WebReport/WEB-INF/lib下拷贝到tomcat的WebReport/WEB-INF/lib下;

fr-applet-8.0.jar:从本地安装目录/WebReport下拷贝到tomcat的/WebReport下;

全部拷贝完成后,重启tomcat,登陆决策平台,看到的就会是8.0的决策平台,说明升级成功。

2.3 本地安装兼容插件

设计器插件安装方法参照设计器插件管理

2.4 服务器安装兼容插件

服务器安装插件方法参照服务器插件管理

重启tomcat,登陆决策平台查看之前开启的“用户同步数据集”和权限管理部分,可以看到已全部兼容升级到8.0

222
222


安装此插件后,不需要做什么操作。8.0版本中就可以正确读取7.1.1版本的平台相关属性。
2.5 测试模板

将7.1所做的所有模板全部放到8.0 的工程下,即从原来的reportlets文件夹下将模板拷贝到8.0安装目录的reportlets下,并将原来WEB-INF/resources文件夹下的datasource.xml文件拷贝到8.0安装目录的WEB-INF/resources文件夹下,datasource.xml文件存放的是数据连接信息,替换完后需要重启8.0的设计器。

当所有模板测试完毕没,没有问题之后,将这些模板全部拷贝到tomcat的报表工程的WEB-INF/reportlets文件夹下,重启tomcat即可。

附件列表


主题: 二次开发
如果您认为本文档还有待完善,请编辑

文档内容仅供参考,如果你需要获取更多帮助,请咨询帆软技术支持
关于技术问题,您还可以通过帆软论坛获取帮助,论坛上有非常多的大神,有些水平比帆软工程师还要高哦。
若您还有其他非技术类问题,可以联系帆软传说哥(qq:1745114201

本文档是否有用?
谢谢! 我们非常感谢您的反馈。
提交反馈: