9.0兼容说明

编辑
文档创建者:susie (58814 )     浏览次数:21029次     编辑次数:33次     最近更新:susie 于 2018-01-10     

目录:

1.引擎编辑

1.1运行环境

在9.0中,为了更好的提升报表计算性能,使用了JDK1.6专用的API,因此9.0版本仅支持JDK1.6-1.8

1.2填报

为了彻底解决大数据量填报展现卡,以及控件样式的可扩展性,进行了填报重构,新填报实现了绝大部分基础功能。但是为了兼容,完全保留了老填报的所有功能,用户可以自主选择使用新填报或者老填报

新填报暂不支持分页填报、离线填报、悬浮元素、列表控件、不支持ie8及以下的浏览器

1.3插件

9.0插件实现了热部署,安装插件时不再需要重启服务器。插件安装后,不再将插件所包含的jar包移动到WEB-INF下的lib文件夹下,而是直接放在plugins文件夹下各个插件各自的包里。

从8.0升级到9.0时,可通过设计器更新升级插件或者平台更新升级插件自动完成原插件jar包移动的动作

1.4定时调度

8.0升级到9.0后,原8.0的任务在9.0中不支持编辑,只支持删除和暂停,但任务可以继续正常运行

1.5设计器

去除单元格右击弹框进行控件、悬浮元素、超级链接、条件属性设置,集中整合到右侧属性面板,让操作更流畅

1.6平台

5.1.将对角色的管理,移到【用户管理】标签下,与机构部门统一交互逻辑

5.2.将【报表管理】标签改名为【目录管理】,并且在同一目录下去掉挂载不同类型的分类,这样可以做到不同类型的混排

1.7其他

6.1.防宕机插件功能进行改进后内置进产品

6.2.将sapbw从多维数据集中拆出

6.3.抛错日志重新整理,统一为8位错误编码

6.4.图表插件内置进产品

1.8 BI

目前9.0不兼容BI 4.0.2版本。BI 4.1可以兼容9.0

2.移动端编辑

2.1报表服务器版本要求

APP9.0版本要求报表服务器为8.0及以上版本,7.1.1报表服务器版本不再维护;

APP9.0暂时不支持BI服务器。

2.2客户端系统版本要求

IOS只支持8.0及以上系统,Android支持4.0及以上系统

2.3只支持新特性图表

APP9.0中只支持新特性图表。如果报表服务器为8.0,更新相应的图表插件后会将老图表转成新图表显示;如果报表服务器为9.0,则老图表会自动转为新图标显示。

新老图表转换过程中,图表显示样式会以新图表为准。详细点击移动端9.0兼容老图表

2.4老地图不兼容

APP9.0中老图表会转为新图表显示,其中地图无法正常转换,需要重新创建。

2.5不支持离线填报功能

APP9.0中不支持离线填报功能

2.6不支持聚合报表

APP9.0中暂不支持聚合报表

2.7摒弃了__replaceview__=true

APP9.0中不再识别__replaceview__=true,可以通过设置链接打开于新窗口或当前窗口来实现当前窗口显示需求。

2.8摒弃了FR.remoteEvaluate(formula)

APP9.0中不再支持FR.remoteEvaluate(formula)这个js

2.9摒弃了contentPane.setAppearRefresh()

APP9.0中不再支持contentPane.setAppearRefresh()这个js

2.10设备绑定功能不兼容

APP9.0需要重新安装,ios设备唯一id是重新生成,升级APP9.0后,需要重新授权

附件列表


主题: 快速入门
如果您认为本文档还有待完善,请编辑

文档内容仅供参考,如果你需要获取更多帮助,请咨询帆软技术支持
关于技术问题,您还可以通过帆软论坛获取帮助,论坛上有非常多的大神,有些水平比帆软工程师还要高哦。
若您还有其他非技术类问题,可以联系帆软传说哥(qq:1745114201

此页面有帮助吗?